Error por falta de libreria de PHP mcrypt

Si instalas cualquier módulo de PHP en tu cms (pasarelas de pago, etc) y recibes este error:


PHP Fatal error: Uncaught Error: Call to undefined function mcrypt_encrypt()


Esto indica que vas a instalar un módulo que necesita la librería mcrypt para poder funcionar pero la versión que tienes seleccionada en tu cuenta no lo soporta.


La extensión de mcrypt dejó de mantenerse a partir de la versión 7.2 de PHP.


Las versiones que lo soportan son las versiones de PHP 5.4 a la 7.1.


Si necesitas usar ese módulo deberás bajar la versión de PHP del dominio o subdominio afectado a la 7.1 o bien contactar con el desarrollador del módulo para que te suministre una versión actualizada que no necesite mcrypt.

¿Ha sido útil esta respuesta? No

Enviar comentario
Por favor ayúdanos a mejorar dejando tus ideas o comentarios