Clave de actualizacion requerida tras actualizar la version de Moodle

Si has actualizado la versión de tu Moodle y al intentar entrar al mismo ves una pantalla donde se pide una clave para poder continuar con alguno de estos mensajes:


  • Español: Clave de actualización requerida
  • Catalán: Cal una clau d'actualització





Esto es porque tienes activada a Upgrade key, esto es, una clave de protección de tu sitio Moodle durante las actualizaciones.


¿Qué es la Upgrade key?

Cuando un sitio Moodle se actualiza como resultado de la actualización del núcleo de Moodle y/o una instalación /actualización de plugins, no hay mecanismos de autenticación y autorización confiables. Cualquier visitante anónimo de tu sitio podría activar el proceso de actualización navegando por su navegador a tu página de administración. Esto puede verse como un riesgo de seguridad porque hay mucha información confidencial (entorno del servidor, versiones de complementos, etc.) disponible en las pantallas de la actualización.


Para mejorar la protección de tu sitio durante la actualización, se recomienda configurar una clave de actualización en tu archivo config.php:


$CFG->upgradekey = 'tu_clave_debe_ponerse_aqui';


No utilices tu contraseña de usuario de administrador como clave de actualización.


Por tanto, en el campo que aparece en esa página, debes poner la contraseña que tienes configurada en el archivo config.php.


Una vez introducida dicha clave, podrás continuar con la actualización de Moodle o instalación de cualquier plugin o complemento.

¿Ha sido útil esta respuesta? No

Enviar comentario
Lamentamos no haber sido de ayuda. Ayúdenos a mejorar este artículo dejándonos sus comentarios.